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Introduction

You can use Microsoft Visual SourceSafe (VSS), Microsoft Visual Studio Team Foundation Server (TFS),
or MorphX VCS for version control in Microsoft Dynamics AX 2009. This document describes how to set
up the Version Control System (VCS) for Microsoft Dynamics AX 2009 by using TFS as your VCS. The
steps involved in setting up version control by using TFS are:

e Set up Microsoft Visual Studio Team Foundation Server on the version control server.
e Set up Team Server (the ID server) on the Team Server computer.

e Set up Microsoft Dynamics AX 2009 and Microsoft Visual Studio Team Explorer on the
administrator computer.

e Configure version control settings in Microsoft Dynamics AX 2009.

Version Control System Considerations

Before you configure Microsoft Dynamics AX 2009 to use TFS for version control, review the
requirements and features of each of the VCS options. For more information about VCS options, see
the version control documentation in Microsoft Dynamics AX 2009.

Setup Overview

Source Control Server | Team Server computer Administrator and
developer computer

Computer e  Visual Studio Team e Supported Operating e  Supported Operating

configuration Foundation Server
and prerequisites

System (See Set up the
Developer and

System (See Set up the
Developer and

Administrator Administrator
Computers later in this Computers later in this
document) document)

e Team Server database .
on Microsoft SQL Server
or Oracle

Microsoft SQL Server or
Oracle

Microsoft Dynamics AX
2009 application,
Application Object Server
(AOS), and client

Visual Studio Team
Explorer

Tasks e Install and set up o

(Admin)

Install and set up o
(Admin)

Install on each computer
(Admin and developers)

Install Microsoft Visual Studio Team Foundation Server

Install Microsoft Visual Studio Team Foundation Server on the source control server by following the
installation instructions in the Visual Studio Team Foundation Installation Guide. If the message,
“Navigation to the webpage was canceled”, appears when you try to access the installation guide, then
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the .chm documentation file might be blocked by your computer. To unblock the documentation file,
right-click the file, and then click Properties. On the General tab, click Unblock.

The documentation for Visual Studio Team System 2008 is located at
http://go.microsoft.com/fwlink/?Linkld=116810.

The documentation for Visual Studio Team System 2005 is located at
http://go.microsoft.com/fwlink/?Linkld=113137.

Install Microsoft Visual Studio Team Explorer

The client portion of TFS is called Team Explorer. Install Team Explorer on the source control server, on
the administrator computer, and optionally on developer computers.

The documentation for Visual Studio Team System 2008 is located at
http://go.microsoft.com/fwlink/?Linkld=116810.

The documentation for Visual Studio Team System 2005 is located at
http://go.microsoft.com/fwlink/?Linkld=113137.

Configure Microsoft Visual Studio Team Foundation Server

Connect Team Explorer to the Team Foundation Server.

1. Open Team Explorer. Click Tools > Connect to Team Foundation Server.

2. Type the name of the Team Foundation Server if it does not appear, and then click OK.

Create a project.

1. Click File > New Team Project.

2. Follow the instructions in the New Team Project Wizard to create a project.

Add all of the developers to the project as members.

1. Click View > Team Explorer to display the Team Explorer.

2. Right-click the project, point to Team Project Settings, and then click Group Membership.

Restrict developer access to the system settings.

We recommend that you restrict access to the VCSdef.xml file to prevent developers from modifying
global version control system settings.

1. Click View > Source Control Explorer.

2. Expand the project, and then double-click Definition.
3. Right-click VCSdef.xml, and then click Properties.

4. Click the Security tab.
5

Modify the permissions of the group that contains the developers so that developers cannot
modify the VCSdef.xml file.

Team Foundation Administrators help is available at http://go.microsoft.com/fwlink/?Linkld=117754.
Learn about widely used Team Foundation source control tasks at
http://go.microsoft.com/fwlink/?LinkID=113138&clcid=0x409.
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Install and Set Up the Team Server (ID Server)

Note: Team Server should not be confused with Team Foundation Server. Team Server is an ID
server that handles the task of issuing unique IDs to objects and labels when they are created.

See the Team Server (ID Server) Setup white paper to set up Team Server at
http://go.microsoft.com/fwlink/?Linkld=120292.

Set Up the Developer and Administrator Computers

Install the Operating System

See http://go.microsoft.com/fwlink/?Linkld=113164&clcid=0x409 for system requirements.

Install MS SQL Server or Oracle
See http://go.microsoft.com/fwlink/?Linkld=113164&clcid=0x409 for system requirements.

Install Microsoft Dynamics AX 2009

See http://go.microsoft.com/fwlink/?Linkld=117123 for access to the Microsoft Dynamics AX 2009
Implementation Guide.

Install Microsoft Visual Studio Team Explorer

The client portion of TFS is called Team Explorer. Installing Team Explorer on developer computers is
optional. To install Team Explorer on developer computers, follow the instructions in the installation
documentation at http://go.microsoft.com/fwlink/?Linkld=113137.

Connect Team Explorer to the Source Control Server Database
1. Open Team Explorer. Click Tools > Connect to Team Foundation Server.

2. Type the name of the Team Foundation Server if it does not appear, select the Team Project, and
then click OK.

Note: Installing Team Explorer on developer computers is optional.

Learn about widely used Team Foundation source control tasks at
http://go.microsoft.com/fwlink/?LinkID=113138&clcid=0x409.

Set Up Local Version Control Parameters (Developer and Administrator)

Create a Local Repository Folder
1. Open Windows Explorer.
2. Create a new folder to use as the local repository folder. For example, C:\VCS_Repository.

Note: Consider the folder you choose for the local repository folder. If a Team Explorer instance
that runs against the source control server shares a local repository folder with a Microsoft Dynamics
AX 2009 client and a change is checked in by using Team Explorer, the Microsoft Dynamics AX 2009
client will not reflect those changes when you synchronize the Microsoft Dynamics AX client unless
you select Force when you synchronize. Installing Team Explorer on developer computers is optional.
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Set Up the Version Control Parameters

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Setup >

Parameters.

Bl ¥ersion control parameters

eneral | Team Foundation Server I

Wersion control setkings

Source conkrol skakus: IEnaI:uIe - I

Yersion control system:

Repository folder:

Environment setkings

Color checked-out obiecks in the A0T: v

W'arn when reverting objects: i

=] B3

Cancel

In Source control status, select Enable.
In Version control system, select Team Foundation Server.
In Repository folder, type the path of the repository folder.

Choose environment settings.

o v~ W N

Click the Team Foundation Server tab.

P8l Yersion control parameters

General Team Foundation Serwver |

Team Foundation Server Settings

Team Foundation Server URL: I htkps ffServeriame: S050 IQ

Team Foundation project name: I F‘rnjectNamel

=] E3

Cancel

[TEAM FOUNDATION SERVER VERSION CONTROL SETUP]




7. In the Team Foundation Server URL field, type the URL of the server that has the TFS project.

8. In the Team Foundation project name field, type the name of the TFS project.

Configure Global Version Control System Settings (Administrator)

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Setup >
System settings.

BBl System settings [_ O]

Genetal |OI:|jEn:I: rules I Additional subfolders I

‘Wersion control setkings

Skatus line: I My Project

Microsoft S0L Server or Oracle: IMicru:-su:nFt SOL Server j

Team Server name: I.ﬁ.xTeamServer "’I

Team Server Database name: IP-XTS| j

Eest practice settings

Compiler warnings: I,a,.;.;ept vI Compiler to-dos: I":"':':Ept vI
Compiler errors; I":"':':Ept vI Best practice erraors: Ip,.;.;ept vI

Fur title case update: [ Tesk project: I j

o | Cancel |

2. In Microsoft SQL Server or Oracle, select the kind of database that the Team Server uses.

3. If you selected Microsoft SQL Server in step 2, type the name of the Team Server in Team Server
name. If you selected Oracle in step 2, type or select the TNS Service name in Team Server TNS

Service Name.

4. If you selected Microsoft SQL Server in step 2, type or select the name of the Team Server

database, such as AXTS, in Team Server Database name. If you selected Oracle in step 2, type or

select the Team Server schema, such as AXTS, in Team Server Schema.

5. Specify best practice settings.

Create Repository

You must add all objects from your master copy of Microsoft Dynamics AX 2009 to the VCS server.
When you add the objects to the server that runs the VCS, they are automatically registered in the
Team Server so that IDs are assigned to them. Assigning IDs to all existing objects ensures that the
Team Server can issue unique IDs for new objects when they are created.
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Create a Local Repository Folder

Create a repository folder on your computer. When you add the Application Object Tree (AOT) objects
to the server, a copy of each object is also added to your repository folder.

Note: Consider the folder you choose for the local repository folder. If a VSS client that runs
against the VSS server shares a local repository folder with a Microsoft Dynamics AX 2009 client and
a change is checked in by using the VSS client, the Microsoft Dynamics AX 2009 client will not reflect
those changes when you synchronize the Microsoft Dynamics AX 2009 client unless you select Force
when you synchronize.

1. Open Windows Explorer.

2. Create a new folder to use as your local repository folder, such as C:\VCS_Repository.

Create Repository

1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Create
repository.

PBl Create repository I =]

Check-in description: | Creation of repository.|

IQ—KI Zancel

2. In Check-in description, type a description of the check-in, such as “Creation of repository.”

3. Click OK.

Synchronize Objects

At first, the local version of Microsoft Dynamics AX 2009 may not be synchronized with the master
version that is deployed by the version control administrator. To access the latest version of all AOT
objects, synchronize the local version with the version that is on the server that is running the version
control system.

8

[TEAM FOUNDATION SERVER VERSION CONTROL SETUP]



1. Click Microsoft Dynamics AX > Tools > Development tools > Version control > Synchronize.
B8 synchronization M= E3

i‘_) Synchronizes the AQT with the latest changes of all objects.,

= Select Force ko start an update regardless of whethet a change has been made.

Forces [
’Q—KI Cancel

2. Indicate whether you want to force the synchronization (optional).
3. Click OK to start synchronization.
Optional Task
Add Ax32Serv.exe as an exception on the Win2K3 Database Server Firewall
1. Click Start > Control panel > Windows Firewall.
2. Select On to turn on the firewall.
3. On the Exceptions tab, click the Add program button.
4. In the Add a program dialog box, browse to locate the Ax32Serv.exe file on your computer, and

then click OK to add it to the list of exceptions.
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Microsoft Dynamics is a line of integrated, adaptable business management solutions that enables you and your
people to make business decisions with greater confidence. Microsoft Dynamics works like and with familiar
Microsoft software, automating and streamlining financial, customer relationship and supply chain processes in a
way that helps you drive business success.

U.S. and Canada Toll Free 1-888-477-7989
Worldwide +1-701-281-6500

www.microsoft.com/dynamics
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